• <dd id="iwhyx"><track id="iwhyx"><video id="iwhyx"></video></track></dd>

    <th id="iwhyx"></th>
  • <progress id="iwhyx"></progress>
    <tbody id="iwhyx"><noscript id="iwhyx"></noscript></tbody>

    當前位置: 主頁 > 百科 > 計算機編程 > 易語言源碼 >
    0 Comments

    源碼取物理磁盤 個數

    發布于:2016-07-05  |   作者:http://www.omfeel.com  |   已聚集:人圍觀

    .子程序 文本模塊_取文本中間_位置, 文本型, 公開, 根據 取文本中間() 推導出的一個命令,這是根據前后兩個字符所在位置,直接把他們取出來 注意:需注意位置是否需要加1或減1,因為操作的是位置,且沒有取文本長度

    .參數 參數文本, 文本型

    .參數 參數開始位置, 整數型, , 1為首位置,2為第2個位置,如此類推。

    .參數 參數結束位置, 整數型

    .局部變量 局變結果文本, 文本型


    .如果真 (參數開始位置 = -1 或 參數結束位置 = -1)

        ' 調試輸出 (“模塊_取文本中間_根據位置”, 參數文本, 參數開始位置, 參數結束位置)

        返回 (“”)

    .如果真結束

    局變結果文本 = 取文本中間 (參數文本, 參數開始位置, 參數結束位置 - (參數開始位置 - 1))  ' 開始位置也算一位

    返回 (局變結果文本)


    .子程序 文本模塊_取整行文本, 文本型, 公開, _根據所在數值 ,得到數值為-1的話,返回空“”| 注意:用尋找文本或倒找文本來取值,防止撮在換行符尾部或不存在的字符位置引起異常  

    .參數 參數之原文本, 文本型

    .參數 參數之得到數值, 整數型

    .局部變量 局變開始位置, 整數型

    .局部變量 局變結束位置, 整數型

    .局部變量 最終返回, 文本型


    .如果真 (參數之得到數值 = -1)

        ' 調試輸出 (“文本模塊_取整行文本_根據所在數值”, 參數之得到數值)

        返回 (“”)

    .如果真結束


    局變開始位置 = 倒找文本 (參數之原文本, #換行符, 參數之得到數值, 假)  ' 往左尋找

    .如果 (局變開始位置 = -1)  ' 說明在第一行啦

        局變開始位置 = 1  ' 1為首位置

    .否則

        局變開始位置 = 局變開始位置 + 2  ' 將開始位置定位回這行首

    .如果結束


    局變結束位置 = 尋找文本 (參數之原文本, #換行符, 參數之得到數值, 假)  ' 往右尋找

    .如果 (局變結束位置 = -1)

        局變結束位置 = 取文本長度 (參數之原文本)  ' 得到最后的數值

    .否則

        局變結束位置 = 局變結束位置 - 1  ' 定位到換行符前一格

    .如果結束


    最終返回 = 文本模塊_取文本中間_位置 (參數之原文本, 局變開始位置, 局變結束位置)

    返回 (最終返回)


    標簽:                   喜歡:收藏
    亚洲五月天天综合色情|成人av弹堂|99久久热视频只有精品5|熟女人妻无码亚洲

  • <dd id="iwhyx"><track id="iwhyx"><video id="iwhyx"></video></track></dd>

    <th id="iwhyx"></th>
  • <progress id="iwhyx"></progress>
    <tbody id="iwhyx"><noscript id="iwhyx"></noscript></tbody>